Pytanie Dlaczego klej pg nie może być zainstalowany w AWS Elastic Beanstalk?


Wdrażam prostą aplikację do AWS Elastic Beanstalk. Jednak moment, w którym się znalazłem gem 'pg' w Gemfile i popchnij je do Elastic Beanstalk. W dziennikach pojawiają się następujące błędy:

-------------------------------------
/var/log/eb-tools.log
-------------------------------------
Installing actionpack (4.0.1) 
Installing mime-types (1.25) 
Installing polyglot (0.3.3) 
Installing treetop (1.4.15) 
Installing mail (2.5.4) 
Installing actionmailer (4.0.1) 
Installing activemodel (4.0.1) 
Installing activerecord-deprecated_finders (1.0.3) 
Installing arel (4.0.1) 
Installing activerecord (4.0.1) 
Installing coffee-script-source (1.6.3) 
Installing execjs (2.0.2) 
Installing coffee-script (2.2.0) 
Installing thor (0.18.1) 
Installing railties (4.0.1) 
Installing coffee-rails (4.0.1) 
Installing hike (1.2.3) 
Installing jbuilder (1.5.2) 
Installing jquery-rails (3.0.4) 
Using json (1.8.1) 
Installing pg (0.17.0) 
Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension.

        /usr/bin/ruby1.9 extconf.rb 
checking for pg_config... no
No pg_config... trying anyway. If building fails, please try again with
 --with-pg-config=/path/to/pg_config
checking for libpq-fe.h... no
Can't find the 'libpq-fe.h header
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

Provided configuration options:
    --with-opt-dir
    --without-opt-dir
    --with-opt-include
    --without-opt-include=${opt-dir}/include
    --with-opt-lib
    --without-opt-lib=${opt-dir}/
    --with-make-prog
    --without-make-prog
    --srcdir=.
    --curdir
    --ruby=/usr/bin/ruby1.9
    --with-pg
    --without-pg
    --with-pg-config
    --without-pg-config
    --with-pg_config
    --without-pg_config
    --with-pg-dir
    --without-pg-dir
    --with-pg-include
    --without-pg-include=${pg-dir}/include
    --with-pg-lib
    --without-pg-lib=${pg-dir}/


Gem files will remain installed in /usr/share/ruby/1.9/gems/1.9.1/gems/pg-0.17.0 for inspection.
Results logged to /usr/share/ruby/1.9/gems/1.9.1/gems/pg-0.17.0/ext/gem_make.out
An error occurred while installing pg (0.17.0), and Bundler cannot continue.
Make sure that `gem install pg -v '0.17.0'` succeeds before bundling.
ERROR: bundle install failed!

2013-11-17 14:10:03,371 [ERROR] (8302 MainThread) [directoryHooksExecutor.py-34] [root directoryHooksExecutor error] Script failed with returncode 1
2013-11-17 14:10:03,499 [INFO] (8269 MainThread) [command.py-130] [root command execute] Command returned: (code: 1, stdout: Error occurred during build: Command hooks failed
, stderr: None)
....

Nie otrzymuję błędów lokalnie.

Całkiem niedawno pamiętam, jak napotkałem ten problem na innych moich skrzynkach Ubuntu. Najwyraźniej trzeba zainstalować dodatkowe biblioteki przez sudo apt-get install ruby-dev build-essential lub sudo apt-get install postgresql-client libpq5 libpq-dev. Dałbym temu szansę, ale na AWS Elastic Beanstalk nie jestem pewien, jak to zrobić.


18
2017-11-17 14:36


pochodzenie




Odpowiedzi:


W .ebextensions/packages.config:

packages:
  yum:
    postgresql-devel: []

Dzięki temu każda nowa instancja będzie miała zainstalowaną tę bibliotekę


22
2017-11-18 12:48



Jak rozwiązałeś ten problem Nie można znaleźć nagłówka "libpq-fe.h" ? To doprowadza mnie do szału przez ostatnie trzy dni. Proszę pomóż! - TheMouseMan
Dzięki, że zadziałało. Jedyny problem polegał na tym, że moje polecenia git nie śledzą .ebextensions / p.config pliki w ogóle. - TheMouseMan
Oznacza to, że na AWS Elastic Beanstalk potrzebujesz postgresql-devel, a nie libpq-dev. To działa, dziękuję. Również dla osób nieświadomych, .ebextensions/packages.config jest katalogiem i plikiem, który ty Utwórz w swoim własnym pakiecie źródłowym: zobacz docs.aws.amazon.com/elasticbeanstalk/latest/dg/.... - Mark Berry


Dodaj

packages:
  yum:
    postgresql93-devel: []

2
2018-03-20 17:14





W .ebextensions/packages.config

packages:
  yum:
    postgresql-devel: []

The ważna rzecz do zapamiętania jest to, że musisz ustawić postgresql-devel aby dopasować bibliotekę do twojej wersji postgresql. np. jeśli masz postgresql 9.4.5, musisz zainstalować postgresql-develXX.

Za pomocą yum list będziesz w stanie zidentyfikować poprawną bibliotekę.


0
2018-03-23 22:24