Pytanie Google Compute Engine Ubuntu 17.04 zesty nie ma już pliku Release


Właśnie utworzyłem nowy serwer Google Cloud Compute Engine, wykorzystując Ubuntu 17.04 jako dysk startowy:

Ubuntu 17.04
amd64 zesty image built on 2017-12-08

Zanim zrobię cokolwiek innego, jeśli spróbuję uruchomić sudo apt-get update Pojawiają się następujące błędy:

Ign:1 http://europe-west1.gce.archive.ubuntu.com/ubuntu zesty InRelease
Ign:2 http://europe-west1.gce.archive.ubuntu.com/ubuntu zesty-updates 

InRelease
Ign:3 http://europe-west1.gce.archive.ubuntu.com/ubuntu zesty-backports InRelease
Ign:4 http://security.ubuntu.com/ubuntu zesty-security InRelease             
Err:5 http://europe-west1.gce.archive.ubuntu.com/ubuntu zesty Release        
  404  Not Found [IP: 35.195.241.40 80]
Err:6 http://europe-west1.gce.archive.ubuntu.com/ubuntu zesty-updates Release
  404  Not Found [IP: 35.195.241.40 80]
Err:7 http://europe-west1.gce.archive.ubuntu.com/ubuntu zesty-backports Release
  404  Not Found [IP: 35.195.241.40 80]
Err:8 http://security.ubuntu.com/ubuntu zesty-security Release               
  404  Not Found [IP: 91.189.88.161 80]
Hit:9 http://archive.canonical.com/ubuntu zesty InRelease                    
Reading package lists... Done                          
E: The repository 'http://europe-west1.gce.archive.ubuntu.com/ubuntu zesty Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://europe-west1.gce.archive.ubuntu.com/ubuntu zesty-updates Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://europe-west1.gce.archive.ubuntu.com/ubuntu zesty-backports Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://security.ubuntu.com/ubuntu zesty-security Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Patrzeć na http://europe-west1.gce.archive.ubuntu.com/ubuntu/ Widzę aktualizacje od dzisiaj mniej niż godzinę temu.

Czy jest to błąd po stronie Google, czy też zrobiłem coś nie tak?


14
2018-01-18 15:24


pochodzenie


Zesty nie jest już obsługiwane, więc musisz go uaktualnić, jak zasugerował Denis - Anders


Odpowiedzi:


Potwierdzam, że "E: repozytorium"http://ru.archive.ubuntu.com/ubuntu "Zesty Release" nie ma już pliku Release. "

Rozwiązany zgodnie z propozycją przed heroina w przepisie https://smyl.es/how-to-fix-ubuntudebian-apt-get-404-not-found-package-repository-errors-saucy-raring-quantal-oneiric-natty/ .

Uruchom to polecenie poniżej na swoim serwerze i zastąpi ono wszystkie adresy URL repozytorium pakietów archive.ubuntu.com i security.ubuntu.com za pomocą old-releases.ubuntu.com

sudo sed -i -e / archive.ubuntu.com \ | security.ubuntu.com/old-releases.ubuntu.com/g '/etc/apt/sources.list

Niestety, polecenie sed nie będzie działać, jeśli wybrałeś narodowy mirror (np us.archive.ubuntu.com dla aktualizacji. Następnie można zaktualizować ciągi w pliku /etc/apt/sources.list zmieniając wszystkie wpisy, takie jak http://*.archive.ubuntu.com i http://*.security.ubuntu.com do http://old-releases.ubuntu.com ręcznie w edytorze tekstu,

sudo nano /etc/apt/sources.list

lub

sudo vi /etc/apt/sources.list

Na przykład Twój http://europe-west1.gce.archive.ubuntu.com/ubuntu zesty InRelease stają się http://old-releases.ubuntu.com/ubuntu zesty InRelease i tak dalej.

Oto mój zaktualizowany plik /etc/apt/sources.list:

# deb cdrom:[Kubuntu 17.04 _Zesty Zapus_ - Release amd64 (20170412)]/ zesty main multiverse restricted universe

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://old-releases.ubuntu.com/ubuntu/ zesty main restricted
# deb-src http://old-releases.ubuntu.com/ubuntu/ zesty main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://old-releases.ubuntu.com/ubuntu/ zesty-updates main restricted
# deb-src http://old-releases.ubuntu.com/ubuntu/ zesty-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://old-releases.ubuntu.com/ubuntu/ zesty universe
# deb-src http://old-releases.ubuntu.com/ubuntu/ zesty universe
deb http://old-releases.ubuntu.com/ubuntu/ zesty-updates universe
# deb-src http://old-releases.ubuntu.com/ubuntu/ zesty-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://old-releases.ubuntu.com/ubuntu/ zesty multiverse
# deb-src http://old-releases.ubuntu.com/ubuntu/ zesty multiverse
deb http://old-releases.ubuntu.com/ubuntu/ zesty-updates multiverse
# deb-src http://old-releases.ubuntu.com/ubuntu/ zesty-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://old-releases.ubuntu.com/ubuntu/ zesty-backports main restricted universe multiverse
# deb-src http://old-releases.ubuntu.com/ubuntu/ zesty-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu zesty partner
# deb-src http://archive.canonical.com/ubuntu zesty partner

deb http://old-releases.ubuntu.com/ubuntu zesty-security main restricted
# deb-src http://old-releases.ubuntu.com/ubuntu zesty-security main restricted
deb http://old-releases.ubuntu.com/ubuntu zesty-security universe
# deb-src http://old-releases.ubuntu.com/ubuntu zesty-security universe
deb http://old-releases.ubuntu.com/ubuntu zesty-security multiverse
# deb-src http://old-releases.ubuntu.com/ubuntu zesty-security multiverse

14
2018-01-24 15:44



Dziękuję Ci za to. Mój główny problem z przejściem na 17.10 to biegacze GitLab nie są (jeszcze) wspierani. Udało mi się tymczasowo to naprawić, ponieważ wszystko inne jest w porządku z 17.10. To doskonała alternatywa dla istniejących serwerów. - chapmanio


17.04 kończy się z dniem 13 stycznia 2018 r. Będziesz musiał przejść do nowszej wersji lub użyć długoterminowej stabilnej wersji: https://wiki.ubuntu.com/Releases


7
2018-01-18 17:06



Ale pytanie dotyczy tylko Google Cloud Compute Engine i /etc/apt/source.list definicja. GCE nie ma sensu oferować Ubuntu 17.04, a potem nie wspierać ich własny definicja w powyższym pliku. Oferują także Ubuntu 14.04 i 16.04, z których oba mogę się uruchomić i uruchomić 'sudo apt-get update` bez żadnych błędów (choć doceniam to, są to długoterminowe stabilne wersje). To wydaje się być błędem z ich strony, ale twój link sugeruje, że nie powinny już oferować 17.04 ... - chapmanio
Mogę potwierdzić, że problem wynika z tego samego powodu, o którym wspominał @Jeremy. Mam dostęp do zespołu backendu, aby zaktualizować obraz GCE Ubuntu 17.04. - Faizan
@Faizan Mogę potwierdzić, że obraz systemu Ubuntu 17.04 został usunięty z listy dysków rozruchowych w GCE. Niestety to mi nie pomaga! - chapmanio
Śledź odpowiedź Denisa, a ty masz rozwiązanie, chapmanio. To nie powinno być problemem z Google Cloud Computer Engine, powinieneś być w stanie edytować plik /etc/apt/sources.list, a następnie zrobić sudo do-release-upgrade jak proponowano. - Anders


Zesty nie ma już pliku wydania, a właściwie "KONIEC CYKLU ŻYCIA"

Miałem ten sam problem, rozwiązanie jest w tym łączu, działa dla mnie ...

https://help.ubuntu.com/community/EOLUpgrades

Mam nadzieję, że moja odpowiedź pomoże.


2
2018-01-25 04:44



Proszę przeczytaj: Czy odpowiedzi, które zawierają linki w innych miejscach, są naprawdę "dobrą odpowiedzią"? - Robert Harvey♦
To jest właściwa odpowiedź, ale Denis umieścił źródła w odpowiedzi, która nie zależy od linków, które mogą się zepsuć. - Anders


Problem wydaje się być nie po stronie Google, ale z tym, że próbujesz uzyskać aktualizacje z HTTP, a nie HTTPS.

Spróbuj skorzystać z tej opcji apt-get:

--allow-unauthenticated
       Ignore if packages can't be authenticated and don't prompt about it. This can be useful while working with local repositories, but is a huge security risk if data authenticity isn't ensured in another way by the
       user itself. The usage of the Trusted option for sources.list(5) entries should usually be preferred over this global override. Configuration Item: APT::Get::AllowUnauthenticated.

0
2018-01-18 15:29



Bieganie sudo apt-get update --allow-unauthenticated zwraca dokładnie taki sam komunikat o błędzie, którego się boję! Nie zmieniłem żadnej konfiguracji itp. Z domyślnego serwera skonfigurowanego z GCE, więc nie powiedziałem, że mam skłonność do pobierania aktualizacji przez http, jest to zachowanie domyślne. - chapmanio
Prawdopodobnie problem polega na tym, że twoja wersja Ubuntu nie jest już obsługiwana (17.04 to nie LTS, a 9 miesięcy wsparcia już powinno minąć). Dlaczego nie po prostu wypróbować świeższą wersję? - heroin
Chociaż możesz wypróbować proponowane rozwiązanie tutaj: smyl.es/... (Nie próbowałem tego). - heroin
Próbowałem tego właśnie teraz. To nie pomogło w rozwiązaniu problemu Zesty - lathomas64
zesty nie jest już wspierany, jak sugerowała heroina. Obserwuj + odpowiedź Denisa Trofinova, a znajdziesz rozwiązanie. Mam ten sam problem i to jest rozwiązanie. Zmienianie repozytoriów na old-release.ubuntu.com tak, jak zrobi to skrypt sed. - Anders