Pytanie ERR_SSL_PROTOCOL_ERROR w chrome 39 i 40, ale działa w chrome 36.Help fix w chrome 39


Mam dostęp do adresu URL w przeglądarce Chrome 36 i IE8, ale w przeglądarce Chrome 39 lub 40 lub Firefox 35 wyświetla się błąd:

Nie można nawiązać bezpiecznego połączenia z serwerem. To może być   problem z serwerem lub może wymagać klienta   certyfikat uwierzytelnienia, którego nie masz.

Kod błędu: ERR_SSL_PROTOCOL_ERROR}.

Wydaje się, że jest to problem związany z certyfikatem SSL. Jak mogę to naprawić?


11
2018-01-19 06:58


pochodzenie




Odpowiedzi:


Google ogłosił że zaczną usuwać obsługę kryptograficznego algorytmu skrótu SHA-1, zaczynając od Chrome 39. Według Google:

Witryny HTTPS, których łańcuchy certyfikatów używają SHA-1 i są ważne od 1 stycznia 2017 r., Nie będą już w pełni wiarygodne w interfejsie użytkownika Chrome.

Istnieje kilka witryn, które mogą zapewnić szczegółową analizę łańcucha certyfikatów SSL, takich jak Test SSL Qualys SSL Labs.

Google Chrome ma bardzo ryzykowny opcja wiersza polecenia --ignore-certificate-errors która może ominąć pewne błędy certyfikatu. Pamiętaj, że ignorowanie błędów certyfikatu naraża cały Twój ruch SSL na ryzyko podsłuchania.

Możliwe jest również, że jest to nowy błąd. Google przełączyło się z korzystania z biblioteki OpenSSL na swoją własną bibliotekę "BoringSSL" w przeglądarce Chrome 38. Aby zgłosić błąd w przeglądarce Chrome chrome://help/ i kliknij "Zgłoś problem".


8
2018-01-20 03:24





Spróbuj tego. W Chrome wpisz "chrome: // flags / # enable-quic" bez cudzysłowów jako adresu URL. CTRL + F, aby wyszukać "quic", w którym momencie znajdziesz ...

Eksperymentalny protokół QUIC. Mac, Windows, Linux, Chrome OS, Android Włącz eksperymentalną obsługę protokołu QUIC. # enable-quic

Odwróć to niepełnosprawnyi pozwól mu ponownie uruchomić przeglądarkę, gdy zostaniesz o to poproszony poniżej.


2
2017-07-02 20:19



Nie działa dla mnie - JGarrido
ani dla mnie nie działało - dzeki


Przejdź do Zapory systemu Windows, kliknij "Przywróć domyślne", a następnie jeszcze raz. Problem powinien zostać naprawiony.


0
2017-09-04 10:34





Dla mnie ten problem został rozwiązany, gdy wyłączyłem kontrolę przeglądania antywirusów.


0
2018-05-13 14:38





Najpierw sprawdź, czy:

  1. Internet Explorer - przejdź do tools/internet options/advanced w polu ustawień przewiń do samego dołu i wybierz Use TLS 1.0 i to rozwiąże problem. Należy również wybrać SSL 2.0 lub 3.0 i te.

  2. Google Chrome - kliknij "klucz" w prawym górnym rogu. Kliknij Options następnie Under the bonnet w sieci kliknij Change Proxy Settings i postępuj zgodnie z instrukcjami powyżej jak w Internet Explorerze.

Jeśli to nie zadziałało, spróbuj wykonać następujące czynności:

  1. Odkryj wszystkie pliki i foldery.
  2. Następnie idź do C:\Windows\System32\drivers\etc\hosts.
  3. Kliknij prawym przyciskiem myszy plik hosts, a następnie kliknij właściwości. Następnie kliknij kartę bezpieczeństwa. Po tym edytowaniu kliknij.
  4. Tutaj kliknij system i musisz zaznaczyć, aby zezwolić na pełną kontrolę i odznaczyć odmowę.
  5. Kliknij OK, a następnie OK.
  6. Teraz usuń plik hosts.

Możesz przeczytać Porady na forum Google z tego miejsca
lub uzyskasz wszystkie szczegóły rozwiązania o err_ssl_protocol_error stąd. Mam nadzieję, że to zadziała i naprawi błąd.


-1
2017-10-18 16:09